Azure Linux VM hang with 100 CPU and cannot SSH

Joshua Tu 1 Reputation point
2020-02-24T04:27:51.993+00:00

Hi experts,

I just got a issue with my Ubuntu VM, all starts from few days back I changed the MTU value for the default eth0, then I cannot use "netstat" anymore. Issued a netstat command will never return any output and after few mins the server hang with 99-100% CPU.

Today I tried to fix this issue by myself and somehow the SSH doesn't connect anymore, tried to Restart the VM from Azure portal doesn't work, then I hit the Stop, waited a few mins and Start the VM. The first try with SSH after the reset can be connected, then issued a htop to check the system status, after like 1 min, the screen hang again, and no SSH can be done to this VM. Another reset can do the trick, but will hang again since the netstat application still consumed 100% CPU... Don't know why.

Any help with this issue? Since I don't have any serial console configured for this VM, now with Performance diagnostics option, the Running performance diagnostics job running forever...

Thanks in advance.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,570 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Lassi Lääti 1 Reputation point
    2020-02-25T05:46:33.417+00:00

    Answering to my previous comment, in which I said we were experiencing similar issues with VM that had some custom network settings.

    My similar issue was solved when I changed the diagnostics storage account settings. VM worked fine previously, suddenly it started acting like this. Under boot diagnostic settings it said that I had no permissions to access the diagnostic storage account. I went ahead and change settings so that everyone can access it, previously it was restricted to some of the VNets (our vpn etc.). This is weird because VM was working just fine for several weeks and problems started yesterday. No settings had been changed on any of the resources.