Trial of Windows server 2019 rebooting despite having rearmed.

AK 16 Reputation points
2022-08-31T06:07:02.203+00:00

Approx. 2 weeks ago I performed the first rearm of a trial Windows Server 2019. However, today I found the server in an off state and after booting it up, I found the reason for the shutdown:

EventID: 1074

The process C:\Windows\system32\wlms\wlms.exe (SERVER_NAME) has initiated the shutdown of computer SERVER_NAME on behalf of user NT AUTHORITY\SYSTEM for the following reason: Other (Planned)  
 Reason Code: 0x80000000  
 Shutdown Type: shutdown  
 Comment: The license period for this installation of Windows has expired. The operating system is shutting down.  

However, slmgr /dli indicates the licnse is still valid for another 157 days:
236377-selection-00904.png

Before the server rebooted, there were several messages related to resource exhaustion such as the one below:

EventID: 2004

Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: spoolsv.exe (3748) consumed 20064985088 bytes, dns.exe (3936) consumed 987471872 bytes, and sqlservr.exe (2896) consumed 454045696 bytes.  

The shutdown was initiated ~1 minute and 28 seconds after that last exhaustion message though I did not see any indication that any of the applications mentioned were terminated meaning that could be the cause.

Any ideas?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,029 questions
{count} votes

5 answers

Sort by: Most helpful
  1. JimmySalian-2011 41,916 Reputation points
    2022-08-31T08:35:46.107+00:00

    Hi,

    Is this VM connected to the Internet? If answer is No try connecting it to the Internet and re-arm again to see if it makes any difference, otherwise my suspect is the applications and resources causing the reboot.

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


  2. rafalzak 3,216 Reputation points
    2022-08-31T09:24:34.16+00:00

    Hi @AK

    It looks something is causing memory leak. Please check drivers installed on the server - i would start from network adapter first.


  3. JimmySalian-2011 41,916 Reputation points
    2022-08-31T09:59:24.087+00:00

    Hi,

    Make sure the spool directory is out of AV scanning sometimes it causes more issues and memory leak. Stop unwanted services if you are not using any of them, check processes and startup services should be able to exclude those.

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


  4. JimmySalian-2011 41,916 Reputation points
    2022-08-31T10:11:25.953+00:00

    Hi,

    Yes the top level folder should be included and files, also check in the task manager what is the process eating up the resources causing memory leak.

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


  5. JimmySalian-2011 41,916 Reputation points
    2022-08-31T10:20:40.847+00:00

    No problem, other thing I recommend is setting custom pagefile on the server a good starting point is 50% of your system Ram, so if you have 16GB Ram you can set this to 8GB which in MB is 8192, enter this value into both boxes then click the ‘Set’ button and then click ‘OK’ the server will now reboot in order to set the page file size to a static one.

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.