Linux VM network doesn't seem to working with SR-IOV enabled

Shubham Chaudhary 1 Reputation point
2022-08-31T07:28:39.423+00:00

Hello,

We are running Ubuntu-20.04 guest on Windows server 2022 Hper-V (v 10.0) with SR-IOV enabled.
On the Network status of the ubuntu 20.04 guest we see - OK(SR-IOV active). but inside VM there's no network connectivity, and we can't seem to ping gateway etc.

Via dmesg we see that VF is active and is assigned to the VM. (log: hv_netsvc eth0: Data path switched to VF: enp40752s1.)

Host network adapter is Broadcom NX-E 10g Base-T.
Ubuntu 20.04 guest Kernel version: 5.15.0.1017-azure ( linux-azure tools installed )

Let me know if any other information is required.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,529 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,331 Reputation points
    2022-09-01T07:55:30.973+00:00

    Hello ShubhamChaudhary

    It would be recommended to post your question in a Linux Ubuntu related questions, as each distro has its own way to configure SR-IOV in the guest machine in order to integrate with the Host network.

    On the other hand, you can too open a question in the next Microsoft Technet Forum, whose community are experts in HyperV - Linux integrations:

    https://social.technet.microsoft.com/Forums/en-US/home?forum=linuxintegrationservices

    -----------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments