Unable to run command in Exchange Powershell

Denis Repp 81 Reputation points


I am trying to run a search on all Exchange mailboxes for some specific text. The following article suggests that this is possible. Is that correct? (Exchange 2019)


As directed by the article, I tried to run the command in step 1

New-ComplianceSearch -Name "Search All-Financial Report" -ExchangeLocation all -ContentMatchQuery 'sent>=01/01/2015 AND sent<=06/30/2015 AND subject:"financial report"'

That command fails, - error says that "The term 'New-ComplianceSearch' is not recognized as the name of a cmdlet..."

Can someone tell me why this command doesn't work?

There's nothing about it in this article, but another one told me that I have to be a member of Compliance Management, Organization Management and Records Managment role groups. Confirmed that I am a member of all three of those.

Thank you for any help you can give me.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,313 questions
No comments
{count} votes

1 additional answer

Sort by: Most helpful
  1. Denis Repp 81 Reputation points

    Thank you for the help, but that did not work. I added myself to that group in the EAC, waited a bit, and confirmed in Powershell that I am now a member.
    I ran the same command again, and got the same error again.

    What next?

    Thank you