Creating Components in Azure ml throws an error after update, how do I resolve it?

Waghbakriwala, Arif 16 Reputation points
2022-08-31T17:02:27.647+00:00

Hey everyone,
I was building components using YAML scripts and it worked pretty fine and everything was smooth as butter until I upgraded the az ml extension & az ml cli extension.
Mostly, reading the error responses helps, but here I am not at all able to debug or trace down into the depth to discover the cause of the issue.

Below is the snippet of the version of extensions and the errors that are popping up:
236643-image.png

For the sake of reference, below is the snippet of yaml file of the component
236567-image.png

Below is the snapshot of the conda file referenced in the above yaml file
236615-image.png

And below is the python script that executes for the corresponding component
236662-image.png

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,560 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,427 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Waghbakriwala, Arif 16 Reputation points
    2022-09-07T13:15:33.133+00:00

    Hi @romungi-MSFT I had tried that as well and it didn't work.
    Here's what worked for me.
    Uninstalling certain libraries as mentioned below:

    python -m pip uninstall azure-common  
    python -m pip uninstall azure-storage  
    python -m pip uninstall azure-nspkg  
    python -m pip uninstall azure-storage-blob  
    

    And then installing the azure ml storage blob again

    python -m pip install azure-storage-blob  
    

    Not really sure what sense it makes but it worked out well, though still generating warnings

    1 person found this answer helpful.
    0 comments No comments