Azure ML Endpoint-Deploy as Webservice Greyed out

Domsohn, Kyle 21 Reputation points
2022-08-31T18:32:12.707+00:00

236628-image.png

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,667 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. YutongTie-MSFT 47,686 Reputation points
    2022-08-31T21:06:04.857+00:00

    Hello @Domsohn, Kyle

    Thanks for using Microsoft Q&A platform. As you see, the "Deploy to web service" option has been upgrade to two new options -
    "Deploy to real-time endpoint" and "Deploy to batch endpoint"

    For more information about the two new options, please refer to this page - https://learn.microsoft.com/en-us/azure/machine-learning/concept-endpoints

    I hope this helps! Those new options make thing easier. Please feel free to use this forum if you have any further questions.

    Regards,
    Yutong

    -Please kindly accept the answer if you feel helpful to support the community, thanks a lot.

    0 comments No comments

  2. Domsohn, Kyle 21 Reputation points
    2022-09-01T13:17:06.07+00:00

    Hi,

    I have been trying to get the "Deploy to real-time endpoint" option to work but the deployment keeps failing with the error below:

    {"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"InferencingClientCreateDeploymentFailed","message":"InferencingClient HttpRequest error, error detail: \"No Environment was provided. Environment is required for custom model formats.\""}]}

    Although, when I create deployments I have option to select an environment.

    236948-image.png

    Thanks,
    Kyle

    0 comments No comments