Xamarin.Forms Http request do not work on deployed app

Bascu 1 Reputation point
2022-09-01T07:59:16.9+00:00

Hello everybody,
I am developing a simple Xamarin.Forms application that does Http requests to a web service i created. When I am on developing mode, everything works fine, also, when I create the desktop app and I run it, it also works properly. However, when I install that desktop app on another computer, Http requests do not work. The app does not crash or anything, it just don't communicate with the web service.

What I did was to run the app from Visual Studio 2019 (with which I developed the app) on that other computer. During compilation, I could see the message "Installing ... frameworks" but I don't exactly know if that is what solved the problem. The thing is that after that, when I run my desktop app, it all works.

My problem here is that I don't like this way of solving the problem, I mean, if every user that wants to use my app has to have the whole code and run it from VS2019, that is not correct at all.

If any of you have had the same problem, or at least have an idea of how to solve this in a more professional way, please let me know

Thanks in advance!!

Xamarin
Xamarin
A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
5,287 questions
{count} votes