CredSSP Oracle remediation steps dont' work

kannan j 1 Reputation point
2022-09-02T09:58:12.757+00:00

I faced CredSSP encyption Oracle authentication error when trying to connect to my VM, and I tried to followed the instructions for the remediation here but they don't work:

$source = 'http:///download.windowsupdate.com/c/msdownlo

ad/update/software/secu/2018/05/windows10.0-kb4103721-x64_fccc746cd817e212ad32a5
606b3db5a33333e030f8.msu'
echo $source
http:///download.windowsupdate.com/c/msdownload/update/software/secu/2018/05/win
dows10.0-kb4103721-x64_fccc746cd817e212ad32a5606b3db5a33333e030f8.msu
$destination = 'c:\temp\windows10.0-kb4103721-x64_fccc74
6cd817e212ad32a5606b3db5a33333e030f8.msu'
echo $destination
c:\temp\windows10.0-kb4103721-x64_fccc746cd817e212ad32a5606b3db5a33333e030f8.msu
$wc = New-Object System.Net.WebClient
$wc.DownloadFile($source,$destination)
Exception calling 'DownloadFile' with '2' argument(s): 'The given path's format is not supported.' At line:1 char:1 + $wc.DownloadFile($source,$destination) + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [], MethodInvocationException + FullyQualifiedErrorId : NotSupportedException

I have tried the msi for R1, R2, etc (as I can't find any information on the Azure Portal which R* is my 2016 Windows server) all failing with the same error.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,515 questions
{count} votes

1 answer

Sort by: Most helpful
  1. KarishmaTiwari-MSFT 18,852 Reputation points Microsoft Employee
    2022-09-13T19:12:26.757+00:00

    @kannan j
    Apologies for the delay on this. I have been trying to reproduce this to be able to apply the remediation steps and test.

    Issue: You are trying to follow the remediation steps to resolve CredSSP encyption Oracle authentication error.

    This error can occur due to the following reasons. Can you please check on the following to see if any of these apply to you :

    1. Ensure that the file that you're trying to download isn't open or being executed at the moment. This exception will be raised if the file is in use.
    2. The folder for the file name/path provided for the $download should exist.
    3. For the WebClient.DownloadFile Method, the first parameter is a Uri address and the second parameter has to be string fileName (The name of the local file that is to receive the data.) and not a path.
      Reference documentation : https://learn.microsoft.com/en-us/dotnet/api/system.net.webclient.downloadfile?view=net-6.0

    Please check the above and let me know the results in the comment. Based on your answer, I can further investigate to see any other potential cause of this error.

    0 comments No comments