Azure SQL Managed Instance remain in Deleting state for days after clicking "Delete"

Mee Lian Lee 1 Reputation point
2022-09-04T10:30:49.607+00:00

I've tried to delete the resource group that contains a sql managed instance and failed with lots of different errors. After that, I started by deleting the sql managed instance only. Unfortunately, it remains in "Deleting" state more than a day and I can't delete all the dependent resources as well. Search through google where everyone was saying max 12 hours and etc but it is still in "Deleting" state. I can't even open a support request for this because it is free tier subscription. Any suggestion?

Azure SQL Database
{count} votes

2 answers

Sort by: Most helpful
  1. JimmySalian-2011 41,961 Reputation points
    2022-09-04T19:22:16.26+00:00

    Hi Mee,

    Did you tried removing via the PowerShell force input? - Remove-AzSqlInstance -Name "managedInstance1" -ResourceGroupName "ResourceGroup01" - Force

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.
    ----
    Please don't forget to upvote and Accept as answer if the reply is helpful


  2. Alberto Morillo 33,176 Reputation points MVP
    2022-09-04T20:19:55.11+00:00

    Please delete the virtual cluster. Follow the steps provided here. Once you do this the resource group deletion may be able to complete. You can also delete now the VNET.

    If after some hours of doing the above, you are unable to see the instance gone, please proceed to create a support ticket to help remove the remnants.