Can't Access Home RDP PC's Since Using Passwordless Authenticator App

Jay 1 Reputation point
2022-09-05T03:57:10.113+00:00

I run 10 older PC's for Folding At Home (FAH) medical research, all on Windows 10 - some x86, some x64. My Microsoft account was hacked so I changed to using only the Authenticator app without a password (I tried just changing my password and it was hacked in minutes ....).

Now I can't connect to any recently setup PC's because no password was entered at setup, but RDP requires one. I really don't think it's reasonable to have to buy an Azure subscription just to make sure these are running properly and to get them going again after Microsoft Updates that require me to fill out entries already answered at setup that prevent Windows from starting FAH (ahem).

Is there a way to RDP with the Authenticator app or a workaround?

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
5,421 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Luke Murray 10,526 Reputation points MVP
    2022-09-05T09:16:32.447+00:00

    Save your RDP connection, ie 'HomePC.rdp'
    Right click and edit in Notepad

    Add the bottom add these 2 lines:

    enablecredsspsupport:i:0
    authentication level:i:2

    Save file and attempt to RDP again, it should skip passwordless auth, which I don't believe is supported for traditional RDP and you can just enter your password into the login prompt. Its what I do to connect to some AAD machines, I have.

    https://stackoverflow.com/questions/62307900/remote-machine-is-aad-but-the-logon-attempt-failed
    https://www.prajwaldesai.com/unable-to-rdp-azure-vm-using-azure-ad-creds/
    https://bradleyschacht.com/remote-desktop-to-azure-ad-joined-computer/

    0 comments No comments