Logic Apps - Analyze Custom Form - Error Message - Specified model not found or not ready, Model Id: [Model Id]

Shiv Patel 1 Reputation point
2022-09-05T04:11:05.803+00:00

I am getting the following error in the logicapps when I tried to use "Analyze Custom Form" in the logic apps. I confirm Model ID multiple times and recreate same activities and retrain model but same result. Please let me know if I am missing anything.

{
"statusCode": 400,
"headers": {
"Request-Context": "appId=cid-v1:ddc6879d-a620-4120-9567-e62f911ac167",
"x-envoy-upstream-service-time": "49",
"apim-request-id": "4ff4df91-20c3-4517-8591-1dc67c0108bf",
"Strict-Transport-Security": "max-age=31536000; includeSubDomains; preload",
"X-Content-Type-Options": "nosniff",
"x-ms-function-status": "OK",
"Date": "Mon, 05 Sep 2022 04:01:25 GMT",
"Content-Length": "120",
"Content-Type": "application/json; charset=utf-8"
},
"body": {
"error": {
"code": "1001",
"message": "Specified model not found or not ready, Model Id: 1st_model_initial_sample_invoice"
}
}
}

Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,816 questions
Azure AI Custom Vision
Azure AI Custom Vision
An Azure artificial intelligence service and end-to-end platform for applying computer vision to specific domains.
206 questions
Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,327 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. romungi-MSFT 41,841 Reputation points Microsoft Employee
    2022-09-05T13:28:29.173+00:00

    @Shiv Patel I believe you have created a model from Azure form recognizer studio using an API version greater than v2.1
    The logic apps connector only supports integration with models created with REST API v2.1 and hence it is unable to list the model when it connects to your FR resource since the API version cannot be configured for newer models. Please see the note on top of this page for details.

    If you are using the model created with v2.1 and still the same error is shown, then the status of model not found or not ready implies that the model failed to train successfully.
    I hope this helps!!

    If an answer is helpful, please click on 130616-image.png or upvote 130671-image.png which might help other community members reading this thread.