Execute process tak error ( Folder does not exist ) running from server

Srinivas K 11 Reputation points
2022-09-05T18:17:30.92+00:00

Hi All,

My name is Sri. I have one issue while running the Execute process task from the server.
Error: execute process task Error : the directory : \ Shared folder]Sri\ does not exist.

I tried with same directory in local solution and it is working fine .. also i tried with using global parameters ( also with out ) in server. But still same issue,

I am able access that directory . but while running from server it is shows error.

Could please some one help me to find out this issue. Not sure if this is the access issue., If yes any suggestion to achieve this .

Thanks in Advance.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,600 questions
SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,449 questions
Transact-SQL
Transact-SQL
A Microsoft extension to the ANSI SQL language that includes procedural programming, local variables, and various support functions.
4,544 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ZoeHui-MSFT 32,406 Reputation points
    2022-09-06T01:41:53.207+00:00

    Hi @Srinivas K ,

    In this scenario, it can't find file when executing package via job, you need to give the permission under that file path for your proxy account.

    running-a-ssis-package-from-sql-server-agent-using-a-proxy-account

    Since you can execute package successfully in SSDT, you can consider change the services account of Agent Job to your current user and try again.

    Regards,

    Zoe Hui


    If the answer is helpful, please click "Accept Answer" and upvote it.