I can’t check for updates on Win Server 2016 VM

Cristóbal Arévalo 1 Reputation point
2020-02-24T16:07:59.17+00:00

Hello when I try to check for updates on my windows server 2016 VM i get the following error
“there were some problems installing updates, but we’ll try again later. If you keep seeing this and want to search the web or contact supoort for information, this may help (0x8024402f)
I have tried recreating, restarting the Vm but nothing seems to fix the problem. I habe read that this is a connectivity error so Im wondering if there’s something I have to configure?
Any ideas?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,409 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Dave Patrick 426.4K Reputation points MVP
    2020-02-24T19:05:48.87+00:00

    You might try downloading directly from update catalog, your ISP may have cached some corrupt files.

    (please don't forget to mark helpful replies as answer)

    1 person found this answer helpful.

  2. Gustavo Ferrari 6 Reputation points
    2020-02-24T23:51:23.547+00:00

    I will try to clean my cache from the update files, for that do this:

    **1. Stop Windows Update Services: **

     •Press Win + R and then type services.msc and hit Enter.    
    
     •Find and double click on Windows Update and then click on  Stop button.    
    

    2. Delete Cache of updates:

     •To delete Update cache, go to - C:\Windows\SoftwareDistribution\Download folder.    
    
     •Press CTRL+A and press Delete to remove all files and folders.    
    
     •Again press Win + R and then type services.msc and hit Enter.    
    

    3. Start Windows Update Services

     •Find and double click on Windows Update and then click on  Start button.    
    

    4. Re do the update

    1 person found this answer helpful.
    0 comments No comments

  3. Kalua_MTA 1 Reputation point
    2020-02-24T23:02:06.797+00:00

    You may need to download the Windows Update Assistant. Sometimes corrupt or missing files may interfere with receiving information for the new update.

    Try this link https://www.microsoft.com/software-download/windows10

    Hope this helps.

    0 comments No comments

  4. Cristóbal Arévalo 1 Reputation point
    2020-02-25T00:19:54.367+00:00

    The thing is that this is a newly deployed VM using Azure’s image of win server 2016. I have tried recreating the VM many times but the problem persists. I will try the suggested fixes.