Error 0x80070643 Failed to uninstall msi package SSMS 19

Prabath 1 Reputation point
2022-09-07T07:34:22.657+00:00

i tried to install ssms and it end up with an error (0x8007064C).I kind a think this is due to previous ODBC driver issue so. I tried to uninstall the driver but its not showing up in control panel or in apps and features tired looking through web site and tired to clean the registries it did not work. I tried deleting left overs but still does not work. please can some one help me?

this is the error I'm getting. i even tired manually downloading the file 'msodbcsql.msi' but it still does not work.
238492-2022-09-07-12-40-02.png238501-2022-09-07-12-41-11.png238493-2022-09-07-12-43-03.png238494-2022-09-07-12-43-32.png

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,913 questions
{count} votes

1 answer

Sort by: Most helpful
  1. PandaPan-MSFT 1,901 Reputation points
    2022-09-07T08:26:03.17+00:00

    Hi @Prabath ,
    238468-image.png According to your error log,we can see that the error was caused by the failure installation of MSI package. You can check this article https://learn.microsoft.com/en-us/troubleshoot/sql/install/restore-missing-windows-installer-cache-files. Follow the guidance to download the FixMissingMSI tool or use the FindSQLInstalls.vbs script. Wish you good luck!
    Best regards
    Jong


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment"

    0 comments No comments