ISAPI dll 403.14 - Forbidden error

Etienne R 21 Reputation points
2022-09-07T10:12:21+00:00

Hello, I checked many threads and tried since 3 days to solve the problem but can't find a solution.

3 days ago my ISAPI dll application worked just fine on my ISS 10 Webserver, then it stopped working.

Setup:
Installed features ISAPI Extension, Filter and CGI
Set Handlers on the default webpage
added my application to the default webpage and entered the physical path
activated 32bit in the default app pool
in the server node I authorized the dll to run and set featurepermissions to accept any module

Now 3 days ago everything worked fine, since then I am unable to get any isapi dll to run. It says 403.14 forbidden all the time.

Internet Information Services
{count} votes

Accepted answer
  1. JimmySalian-2011 41,926 Reputation points
    2022-09-07T10:20:37.617+00:00

    Hi,

    Do you see any event ID in the Event Viewer? However for this error you will need to implement the fix if you have access to the server.

    appcmd set config /section:directoryBrowse /enabled:truehttp-403-14-forbidden-webpage

    ==
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


0 additional answers

Sort by: Most helpful