IE Mode - not working - confused

Paul W. Specht 1 Reputation point
2022-09-07T15:20:22.793+00:00

Im getting confused by this. I have one site (for now) that cannot be run in Edge. I was able to get the site to work by setting IE mode for the site in Edge as a test.
So I want to set a GPO now to make it more than 30 days.

I see conflicting info settings online.

I want to use the Enterprise site list (https://learn.microsoft.com/en-us/deployedge/edge-ie-mode-site-list-manager)
But the program is different than the instructions. I dont have the list of Open in:
So I chose Open in: MSedge, Compat Mode: Default
I added the site (www.site.com) and created the xml. placed it on a test machine under C:\temp\Edge

Now the GPOs

Here are my steps I took (https://learn.microsoft.com/en-us/deployedge/edge-ie-mode-policies#configure-internet-explorer-integration)

I downloaded the admx files from here -> https://www.microsoft.com/en-us/edge/business/download
I placed the adml files (msedge and msedgeupdate) in C:\Windows\PolicyDefinitions\en-US. But when I didnt see the other options listed in the docs I also added the admx to C:\Windows\PolicyDefinitions.

Created a test GPO
in here Computer Configuration > Administrative Templates > Microsoft Edge.

Configure the Enterprise Mode Site List
local file set up as file:///c:/temp/Edge/sites.xml. Is this correct?
If this works I plan on moving it to a network share.

But after I run gpupdate, I go here in Edge edge://compat/enterprise I do not see the list location

I also want to note that I set the GPO to link to the Test PC OU, not enforced, and link is enabled.
And I set the delegation to Auth users read and added the PC I'm testing on, and set apply group policy to allow
The testing PC is in the Test PC OU.

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,119 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Paul W. Specht 1 Reputation point
    2022-09-07T20:14:23.833+00:00

    ****UPDATE****

    I copied the admx and amdl files to the incorrect spot??

    I copied another set to here:
    C:\Windows\SYSVOL\sysvol\DOMAIN.com\Policies\PolicyDefinitions &
    C:\Windows\SYSVOL\sysvol\DOMAIN.com\Policies\PolicyDefinitions\en-US

    NOW I see the options Computer Configuration > Administrative Templates > Microsoft Edge

    0 comments No comments