Some users cant connect to windows 2019 server with rdp

Bora Özden 6 Reputation points

Hi , this is a long lasting and important urgent problem. Hope someone will help to solve the problem.

We have a windows 2019 server which we want some AD users to connect with rdp and use a browser. We defined the releated users on the 2019 servers control panel system remote settings

remote desktop select users as remote desktop users /group. After a while some of them (especially after changing their AD password) started to unable to connect to the server. Their password is not accepted , but they can able to logon to their local windows 10 box with their changed password. On the server we tried to install RDS services before but it installed corruptly and with error, and i can see as new only RD licensing diagnoser and it says its not configured. Also grace period is coming soon , so while we need to fix the situation urgently , we will need to installa and configure a new server and if needed find licenses for it.

This is a very urgent problem so ill be happy if you can help. Thanks

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,235 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. JimmySalian-2011 41,916 Reputation points

    Hi @Bora Özden ,

    it seems the users cache profile is stored on the server and could be causing the connection issue with the new password, also check if the password is updated in the RDP connection. Here is the detailed step by step guide for setting up the RDS server on 2019.
    Also check the credential manager on the local device if cache credentials are there and updated?


    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments

  2. Bora Özden 6 Reputation points


    Thank you for your answer. How can i check the controls you have mentioned and fix them?


  3. Bora Özden 6 Reputation points

    Thanks, But credential manager seems unable to solve the problem.

    Also when i logon to the server with the administrator user, i cant change the NLA option and disable it. The options are grayed out.

    0 comments No comments