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User Profile Sync Service stuck on 'Starting'

Symptoms

While starting the UPA Sync service, it remains in starting phase and we get
the following error in ULS logs -

OWSTIMER.EXE (0x04E4) 0x1390 SharePoint Portal Server User Profiles hyc6 High

Exception occured while connecting to WCF endpoint:
System.ServiceModel.ServerTooBusyException: The HTTP service located at https://servername:32843/f7d385690f414db0b5cee0da8d112e35/ProfilePropertyService.svc
is too busy. ---> System.Net.WebException: The remote server returned an
error: (503) Server Unavailable.
at System.Net.HttpWebRequest.GetResponse()

at
System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan
timeout) -
-- End of inner exception stack trace --- Server stack trace:

at
System.ServiceModel.Channels.HttpChannelUtilities.ProcessGetResponseWebException(WebException
webException, HttpWebRequest request, HttpAbortReason abortReason)
at
System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan
timeout)
at System.ServiceModel.Channels.RequestChannel.Request(Message
message, TimeSpan timeout)
at
System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message
message, TimeSpan timeout)
at
System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message,
TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String
action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[]
outs, TimeSpan timeout)
at
System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage
methodCall, ProxyOperationRuntime operation)
at
System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)
Exception rethrown
at [0]:
at
System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg,
IMessage retMsg)
at
System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&
msgData, Int32 type)
at
Microsoft.Office.Server.UserProfiles.IProfilePropertyService.GetProfileProperties()

at
Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.<>c__DisplayClass1.b__0(IProfilePropertyService
channel)
at
Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String
operationName, CodeBlock codeBlock)

and

[ Date and Time ]  w3wp.exe (0x0AE4) 0x0EBC SharePoint Portal Server User
Profiles g11n High
UserProfileApplicationProxy.InitializePropertyCache:
Microsoft.Office.Server.UserProfiles.UserProfileException:
System.ServiceModel.ServerTooBusyException
at
Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String
operationName, CodeBlock codeBlock)
at
Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String
operationName, CodeBlock codeBlock)
at
Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()

at
Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid
applicationID)
at
Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)
at
Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean
asynchronous)
at
Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache()

--- Cannot get the application ID:

w3wp.exe (0x0AE4) 0x0EBC SharePoint Portal Server User Profiles d22b High
Failure retrieving application ID for User Profile Application Proxy 'URS Sourse
Test User Profile Service 2': System.NullReferenceException: Object reference
not set to an instance of an object.
at
Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()

at
Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_AppID()

--- Cannot get_CurrentApplicationProxy:

w3wp.exe (0x0AE4) 0x0EBC SharePoint Portal Server User Profiles et8j High
UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception:
Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException:
This User Profile Application's connection is currently not available. The
Application Pool or User Profile Service may not have been started. Please
contact your administrator.
at
Microsoft.SharePoint.Portal.UserProfiles.AdminUI.ProfileAdminPage.get_CurrentApplicationProxy()

at
Microsoft.SharePoint.Portal.WebControls.UserProfileServiceStatisticsWebPartBase.LoadControl(Object
sender, EventArgs e)

Cause

Farm account password was changed recently. It was only changed on application pool but was not applied globally via SharePoint CA.


Resolution

The password for the farm and UPA account was changed
The change was made directly from the IIS manager and not from the SharePoint Central Administration
Browsed to 'CA > Security > Configure Managed accounts' and applied the new password for the account.

We granted the required permissions for the account in order to start the User Profile Synchronization Service
Started the UPA Sync service successfully.