CCE 展開環境で会議へのエスカレーションに失敗する
Japan Lync/Skype Support チームの和気です。
今回は、CCE 展開環境における会議へのエスカレーションにおける既知の問題についてご案内いたします。
本問題については、仲介サーバーに関する設定を行うことで改善します。しかしながら、つい先日まで、本手順が CCE 構築時に必要な手順として弊社公開資料に記載がない状況であったため、本 Blog にて改めてご紹介させていただきます。
[事象]
PSTN 番号と通話中に 3 人目の ユーザー (Skype for Business ユーザーもしくは電話番号) を追加した場合、以下のエラーが発生し、3 人目のユーザーを招待することができません。なお、既存の通話は続行されます。
[原因]
Skype for Business Online の会議サービスから CCE の仲介サーバーに対する通信を適切にルーティングできないために、本問題が発生いたします。
ルーティングの問題は、追加の仲介サーバーの設定 (Set-CsHybridMediationServer) を行っていただくことで改善します。
P2P の通話中に 3 人目のユーザーを追加した場合、内部的には、会議ディレクトリが作成され、各ユーザーが作成された Skype for Business Online 上の会議に接続先を切り替えます。(会議へのエスカレーション)
PSTN 番号と会議の接続においては、Skype for Business Online 上の会議サービスから CCE のエッジ サーバーを介して仲介サーバーに INVITE メッセージが送られメディアネゴシエーションが行われる動作となりますが、この際に会議サービスから仲介サーバーに適切にルーティングができず、その結果として既存ユーザーの会議へのエスカレーションに失敗し、エラーが発生します。
また、既存ユーザーの会議へのエスカレーションに失敗しているため、3 人目のユーザーの招待も実行されません。
[対処方法]
CCE 展開環境において、以下の手順で CCE 仲介サーバーに関する設定を行ってください。
- Office 365 管理センターで、CCE の既定の SIP ドメイン (※) を使用した任意の名前のオンライン ユーザーを作成します。
※ ini ファイルの "SIPDomains" で指定したドメイン (複数指定している場合は、先頭に記載したドメイン)
例 :medsvr@contoso.com
_なお、本手順で作成したユーザーにはライセンスを割り当てないようお願いいたします。Skype for Business Online のディレクトリに反映するため、作成したアカウントに一旦 Skype for Busines Online のライセンスを割り当てます。通常であれば一時間程度で反映され、その後ライセンスを削除します。
※2018/08/21 - 英語原文における以下更新にあわせて修正いたします。
Please note that license assignment is only required for the user propagation into the Skype for Business online directory. Assign an Office 365 licenses (such as E5) to the account you create, allow up to one hour for the changes to propagate, then remove the license from this account. - Office 365 との ディレクトリ 同期が完了するまで待ちます。
- 以下のコマンドを使用して、手順 1 で作成したユーザーに仲介サーバーとエッジ サーバーの FQDN を指定します。
> Set-CsHybridMediationServer -Identity medsvr@contoso.com -Fqdn med.contosocce.lab -AccessProxyExternalFqdn aep.contoso.co- - Identity : 手順 1 で作成したユーザー
- - Fqdn : CCE の仲介サーバーの内部 FQDN
- - AccessProxyExternalFqdn : CCE のアクセス エッジの FQDN
- 複数の CCE 仲介サーバーがある場合 (マルチサイト構成、もしくは HA 対応の単一サイト構成で CCE を構築する場合) は、前述の手順を各サーバーに対して繰り返してください。具体的には、各 CCE インスタンスの仲介サーバーに対応するユーザーを作成し、各ユーザーに対して Fqdn パラメーター、および AccessProxyExternalFqdn パラメーターを設定してください。
[弊社ドキュメントの修正について]
上記 [対処方法] でご紹介した手順については、当初 CCE 展開におけるトラブルシューティング集では案内されておりましたが、実際には、本手順は CCE 構築時に必要な手順であるため、現在、CCE 構築手順の資料に追加するよう更新作業が進められています。
本日時点では、まだ英語版資料の更新のみが完了した状況となりますが、今後英語版に合わせて日本語版の資料も更新がなされる予定です。
参考 : CCE 構築手順における 仲介サーバーの設定について
英語版 (原文)、仲介サーバーの設定について更新済
Title : Configure Cloud Connector integration with your Office 365 tenant >>> Configure online hybrid Mediation Server Settings
URL : https://technet.microsoft.com/en-us/library/0e2f2395-b890-4d16-aa2d-99d52438b89c#BKMK_ConfigureMediationServer
日本語版、仲介サーバーの設定については今後更新予定 (現時点では未記載)
Title : Cloud Connector と Office 365 テナントの統合を構成する
URL : https://technet.microsoft.com/ja-jp/library/mt740651.aspx
参考: CCE 展開環境におけるトラブルシューティング集
Title : Cloud Connector 展開のトラブルシューティング
URL : https://technet.microsoft.com/en-us/library/mt740658.aspx (英語版)
URL : https://technet.microsoft.com/ja-jp/library/mt740658.aspx (日本語版)
※ 本問題については「問題: PSTN 番号を使って Skype for Business クライアントから通話を発信するとき、別の PSTN 番号を招待することで電話会議に通話をエスカレートできない。 」の項を参照ください。
本情報の内容 (添付文書、リンク先などを含む) は、作成日時点でのものであり、予告なく変更される場合があります。