Share via


Clients behind ISA/TMG get Network Access Message “Error Code 10061: Connection refused” in browser while accessing internet intermittently. As this page is displayed by TMG or ISA Server lot of people think that its an issue with TMG/ISA

Symptoms

Intermittently users browing internet through ISA/TMG will get “Error Code 10061: Connection refused”

Cause

In my case it was the device in front of TMG that was causing the issue.
 

Resolution

We took a Network Trace on TMG and found that device in front of TMG was Resetting SYN packet sent by TMG while accessing website.

Later on customer opened a case with Firewall Vendor and there was a bug in their device.

Network Monitor Download Link:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f