EXPORT_TO_OSSIE error condition

SQLSTATE: 42K0E

Cannot read Apache Ossie YAML from the metric view.

FEATURE_DISABLED

The export_to_ossie function is disabled. Please make sure "spark.databricks.sql.metricView.exportToOssie.enabled" is set to true.

INVALID_DEFINITION

The metric view <name> has no stored definition to convert.

NOT_A_METRIC_VIEW

<name> is not a metric view (table type: <tableType>).

NOT_REPRESENTABLE_IN_OSSIE

The metric view <name> cannot be represented in Apache Ossie: <message>

REQUIRES_TABLE_ARGUMENT

The <functionName> function requires the metric view to be referenced by name as a TABLE argument, for example, export_to_ossie(TABLE(catalog.schema.metric_view)).

UNSUPPORTED_VERSION

The metric view <name> is stored as version <version>, which cannot be converted to Apache Ossie. Only version 1.1 is supported.