Scenario: Unable to read Apache Yarn log in Azure HDInsight
This article describes troubleshooting steps and possible resolutions for issues when interacting with Azure HDInsight clusters.
Issue
The Apache Yarn logs found from storage account isn't human-readable. The file parser doesn't work and produces the following error message:
java.io.IOException: Not a valid BCFile.
Cause
The Apache Yarn log is aggregated into IndexFile
format, which is not supported by the file parser.
Resolution
From a web browser, navigate to
https://CLUSTERNAME.azurehdinsight.net
, whereCLUSTERNAME
is the name of your cluster.From Ambari UI, navigate to YARN > Configs > Advanced > Advanced yarn-site.
For WASB storage: The default value for
yarn.log-aggregation.file-formats
isIndexedFormat,TFile
. Change the value toTFile
.For ADLS storage: The default value for
yarn.nodemanager.log-aggregation.compression-type
isgz
. Change the value tonone
.Save the change and restart all affected services.
Next steps
If you didn't see your problem or are unable to solve your issue, visit one of the following channels for more support:
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