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This article describes troubleshooting steps and possible resolutions for issues when using Interactive Query components in Azure HDInsight clusters.
Issue
The Hive View is inaccessible, and the logs in /var/log/hive
show an error similar to the following:
ERROR [Curator-Framework-0]: curator.ConnectionState (ConnectionState.java:checkTimeouts(200)) - Connection timed out for connection string (<zookeepername1>.contoso.com:2181,<zookeepername2>.contoso.com:2181,<zookeepername3>.contoso.com:2181) and timeout (15000) / elapsed (21852)
Cause
It is possible that Hive may fail to establish a connection to Zookeeper, which prevents the Hive View from launching.
Resolution
Check that the Zookeeper service is healthy.
Check if the Zookeeper service has a ZNode entry for Hive Server2. The value will be missing or incorrect.
/usr/hdp/2.6.2.25-1/zookeeper/bin/zkCli.sh -server <zookeepername1> [zk: <zookeepername1>(CONNECTED) 0] ls /hiveserver2-hive2
To re-establish connectivity, reboot the Zookeeper nodes, and reboot HiveServer2.
Next steps
If you didn't see your problem or are unable to solve your issue, visit one of the following channels for more support:
Get answers from Azure experts through Azure Community Support.
Connect with @AzureSupport - the official Microsoft Azure account for improving customer experience. Connecting the Azure community to the right resources: answers, support, and experts.
If you need more help, you can submit a support request from the Azure portal. Select Support from the menu bar or open the Help + support hub. For more detailed information, review How to create an Azure support request. Access to Subscription Management and billing support is included with your Microsoft Azure subscription, and Technical Support is provided through one of the Azure Support Plans.