Java.Security.Spec Namespace
Important
Some information relates to prerelease product that may be substantially modified before it’s released. Microsoft makes no warranties, express or implied, with respect to the information provided here.
This package provides the classes and interfaces needed to specify keys and parameters for encryption and signing algorithms.
Classes
DSAParameterSpec |
This class specifies the set of parameters used with the DSA algorithm. |
DSAPrivateKeySpec |
This class specifies a DSA private key with its associated parameters. |
DSAPublicKeySpec |
This class specifies a DSA public key with its associated parameters. |
ECFieldF2m |
This immutable class defines an elliptic curve (EC) characteristic 2 finite field. |
ECFieldFp |
This immutable class defines an elliptic curve (EC) prime finite field. |
ECGenParameterSpec |
This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters. |
ECParameterSpec |
This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC). |
ECPoint |
This immutable class represents a point on an elliptic curve (EC) in affine coordinates. |
ECPrivateKeySpec |
This immutable class specifies an elliptic curve private key with its associated parameters. |
ECPublicKeySpec |
This immutable class specifies an elliptic curve public key with its associated parameters. |
EdECPoint |
An elliptic curve point used to specify keys as defined by RFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA). |
EdECPrivateKeySpec |
A class representing elliptic curve private keys as defined in RFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA), including the curve and other algorithm parameters. |
EdECPublicKeySpec |
A class representing elliptic curve public keys as defined in RFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA), including the curve and other algorithm parameters. |
EllipticCurve |
This immutable class holds the necessary values needed to represent an elliptic curve. |
EncodedKeySpec |
This class represents a public or private key in encoded format. |
InvalidKeySpecException |
This is the exception for invalid key specifications. |
InvalidParameterSpecException |
This is the exception for invalid parameter specifications. |
MGF1ParameterSpec |
This class specifies the set of parameters used with mask generation function MGF1 in OAEP Padding and RSA-PSS signature scheme, as defined in the PKCS #1 v2.1 standard. |
NamedParameterSpec |
This class is used to specify any algorithm parameters that are determined by a standard name. |
PKCS8EncodedKeySpec |
This class represents the ASN. |
PSSParameterSpec |
This class specifies a parameter spec for RSA-PSS signature scheme, as defined in the PKCS#1 v2.1 standard. |
RSAKeyGenParameterSpec |
This class specifies the set of parameters used to generate an RSA key pair. |
RSAMultiPrimePrivateCrtKeySpec |
This class specifies an RSA multi-prime private key, as defined in the PKCS#1 v2. |
RSAOtherPrimeInfo |
This class represents the triplet (prime, exponent, and coefficient) inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2. |
RSAPrivateCrtKeySpec |
This class specifies an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values for efficiency. |
RSAPrivateKeySpec |
This class specifies an RSA private key. |
RSAPublicKeySpec |
This class specifies an RSA public key. |
X509EncodedKeySpec |
This class represents the ASN. |
XECPrivateKeySpec |
A class representing elliptic curve private keys as defined in RFC 7748, including the curve and other algorithm parameters. |
XECPublicKeySpec |
A class representing elliptic curve public keys as defined in RFC 7748, including the curve and other algorithm parameters. |
Interfaces
IAlgorithmParameterSpec |
A (transparent) specification of cryptographic parameters. |
IECField |
This interface represents an elliptic curve (EC) finite field. |
IKeySpec |
A (transparent) specification of the key material that constitutes a cryptographic key. |