MvcCoreMvcBuilderExtensions.SetCompatibilityVersion Method

Definition

Caution

This API is obsolete and will be removed in a future version. Consider removing usages.", DiagnosticId="ASP5001", UrlFormat="https://aka.ms/aspnetcore-warnings/{0}

Sets the CompatibilityVersion for ASP.NET Core MVC for the application.

public static Microsoft.Extensions.DependencyInjection.IMvcBuilder SetCompatibilityVersion (this Microsoft.Extensions.DependencyInjection.IMvcBuilder builder, Microsoft.AspNetCore.Mvc.CompatibilityVersion version);
[System.Obsolete("This API is obsolete and will be removed in a future version. Consider removing usages.", DiagnosticId="ASP5001", UrlFormat="https://aka.ms/aspnetcore-warnings/{0}")]
public static Microsoft.Extensions.DependencyInjection.IMvcBuilder SetCompatibilityVersion (this Microsoft.Extensions.DependencyInjection.IMvcBuilder builder, Microsoft.AspNetCore.Mvc.CompatibilityVersion version);
static member SetCompatibilityVersion : Microsoft.Extensions.DependencyInjection.IMvcBuilder * Microsoft.AspNetCore.Mvc.CompatibilityVersion -> Microsoft.Extensions.DependencyInjection.IMvcBuilder
[<System.Obsolete("This API is obsolete and will be removed in a future version. Consider removing usages.", DiagnosticId="ASP5001", UrlFormat="https://aka.ms/aspnetcore-warnings/{0}")>]
static member SetCompatibilityVersion : Microsoft.Extensions.DependencyInjection.IMvcBuilder * Microsoft.AspNetCore.Mvc.CompatibilityVersion -> Microsoft.Extensions.DependencyInjection.IMvcBuilder
<Extension()>
Public Function SetCompatibilityVersion (builder As IMvcBuilder, version As CompatibilityVersion) As IMvcBuilder

Parameters

builder
IMvcBuilder

The IMvcBuilder.

version
CompatibilityVersion

The CompatibilityVersion value to configure.

Returns

IMvcBuilder

The IMvcBuilder.

Attributes

Applies to