Microsoft Dynamics 365 Finance + Operations (on-premises) supported software

This article explains which versions of dependent software are compatible with different versions of Microsoft Dynamics 365 Finance + Operations (on-premises).

Microsoft Windows Server

Both Microsoft Windows Server Standard and Microsoft Windows Server Datacenter are supported.

Version Supported since End of life
Microsoft Windows Server 2022 10.0.38 Not available
Microsoft Windows Server 2019 10.0.17 10.0.41
Microsoft Windows Server 2016 Original release 10.0.26

Note

Only en-US operating system installations are supported. These software requirements are relevant to all non-Microsoft managed environments, including development boxes, cloud-hosted environments, and similar setups.

Microsoft SQL Server

Both Microsoft SQL Server Standard Edition and Enterprise Edition are supported.

This section covers the following SQL Server components:

  • Database Engine
  • SQL Server Reporting Services (SSRS)
  • SQL Server Integration Services (SSIS)
Version Supported since End of life
Microsoft SQL Server 2019 10.0.21 Not available
Microsoft SQL Server 2016 SP2 10.0.9 10.0.28
Microsoft SQL Server 2016 SP1 Original release 10.0.14

Important

Using multiple versions of Microsoft SQL Server throughout a single environment is not supported.

Active Directory Federation Services (AD FS)

Active Directory Federation Services (AD FS) is a server role that can be installed on a machine running Windows Server.

Version Supported since End of life
Active Directory Federation Services on Windows Server 2022 10.0.38 Not available
Active Directory Federation Services on Windows Server 2019 10.0.17 Not available
Active Directory Federation Services on Windows Server 2016 Original release 10.0.26

Important

  • AD FS on Windows Server 2016 only supports authentication through the Microsoft Entra Authentication Library (ADAL).
  • In order to uptake the upcoming migration to the Microsoft Authentication Library, you need to deploy your AD FS on Windows Server 2019 (MSAL). For more information, see Migrate applications to the Microsoft Authentication Library (MSAL).
  • After July 1, 2022, any customers still using AD FS on Windows Server 2016 will no longer be able to use the Office add-ins. This is irrespective of the Microsoft Dynamics 365 Finance + Operations (on-premises) version that they are running.

Minimum Azure Service Fabric runtime

Your Service Fabric cluster should always be on a supported version according to the official documentation, Service Fabric supported versions.

Minimum version Required since
Service Fabric runtime 8.2 10.0.30
Service Fabric runtime 8.0 10.0.24
Service Fabric runtime 7.2 10.0.17
Service Fabric runtime 7.1 10.0.14

Minimum Microsoft .NET Framework runtime

The requirements for .NET Framework are specified on a per node basis. For specific features and versions, see Set up and deploy on-premises environments (Platform update 41 and later).

Minimum version Required since
Microsoft .NET Framework version 4.7.2 10.0.11

Microsoft Office Server

Office Server is an optional component. For more information, see Configure document preview.

Version Supported since End of life
Microsoft Office Server 2017 10.0.0 Not available