"550 5.1.1 RESOLVER.ADR.ExRecipNotFound" when sending emails by using Outlook in Microsoft 365
Original KB number: 2784785
Problem
When you send email messages by using Microsoft Outlook in Microsoft 365, you may experience one or both of the following issues:
Symptom 1: You receive non-delivery reports (NDRs)
Email messages or meeting invitations aren't delivered successfully. For example, you receive an NDR that resembles the following example:
Generating server: <server name>.local
IMCEAEX-_O=CONTOSO_ou=first+20administrative+20group_cn=Recipients_cn=<username>@<server name>.local
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
Symptom 2: The AutoComplete feature in Outlook doesn't work as expected
When you create a new email message and then type a name in the To line, the user's name is auto-populated. However, when you double-click the name, you experience one of the following issues:
- The dialog box information isn't displayed correctly.
- Information is missing from the dialog box.
Cause
These issues may occur if one of the following conditions is true:
- You reply to messages that were migrated from personal folders (.pst) files or were migrated by using a third-party migration tool.
- The Outlook nickname cache (AutoComplete) contains a bad entry.
- The OfflineAddressBook isn't updated or can't be downloaded.
Solution
To resolve these issues, follow these steps:
Reset the nickname and the autocomplete caches in Outlook. For more information about how to do so, see Information about the Outlook AutoComplete list.
If you reply to a migrated message, type the whole email address of the recipient again. If the Autocomplete feature tries to input the recipient name or address for you, select the 'X' to delete the entry, and then manually type the whole email address again.
Make sure that the Offline Address Book is operating correctly. For more information about how to troubleshoot the Offline Address Book, see How to troubleshoot the Outlook Offline Address Book in a Microsoft 365 environment.
More information
This issue most frequently occurs when messages are migrated by using a method that doesn't correctly update the underlying X.500 distinguished name information for the original recipients of the message. The most common culprits in this scenario are .pst migrations.
For more information, see the following resources:
- What are Exchange NDRs in Exchange Online and Microsoft 365
- Error code 5.1.1 through 5.1.20 in Exchange Online and Microsoft 365
Still need help? Go to Microsoft Community.