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"554 5.2.0 STOREDRV.Deliver.Exception" when sending emails in Exchange Online

Problem

When users send messages to a specific mailbox in Exchange Online, they receive a nondelivery report that contains the following error code:

554 5.2.0 STOREDRV.Deliver.Exception:ObjectNotFoundException.MapiExceptionNotFound; Failed to process message due to a permanent exception with message Cannot get ID from name

For example, users may experience this issue when they send mail to a distribution group.

Cause

This issue occurs if the Clutter feature is enabled for the user but the Clutter folder is missing in the user's mailbox.

Workaround

To work around this issue, turn off Clutter for the user. To do this, use one of the following methods.

Method 1: Use Outlook on the web

  1. In Outlook on the web, click Settings in the upper-right corner.
  2. Click My app settings, click Mail, and then click Clutter.
  3. Clear the Separate items identified as clutter check box, and then click Save.

For more information about how to turn Clutter on or off, see Use Clutter to sort low priority messages in Outlook 2016 for Windows.

Method 2: Use Exchange Online PowerShell

  1. Connect to Exchange Online by using PowerShell. For more information, see Connect to Exchange Online using remote PowerShell.

  2. Run the following command:

    Get-Mailbox user@contoso.com | Set-Clutter -Enable $false
    

For more information about how to use the Set-Clutter cmdlet to turn Clutter on or off, see Set-Clutter.

More information

Still need help? Go to Microsoft Community.