"550 5.1.10 RESOLVER.ADR.RecipientNotFound" when Microsoft 365 users send emails to on-premises users in a hybrid deployment
Original KB number: 3197393
Problem
A Microsoft 365 user is unable to send email messages to on-premises Exchange users in an Exchange hybrid deployment. The Microsoft 365 user receives the following nondelivery report (NDR):
Your message to User@contoso.com couldn't be delivered.
User wasn't found at <contoso.com>
The NDR contains the following error code:
550 5.1.10 RESOLVER.ADR.RecipientNotFound; Recipient not found by SMTP address lookup
Cause
This problem occurs if the user was created in Microsoft 365. In this scenario, the on-premises Exchange environment has no object to reference for the user. Therefore, all queries for that SMTP address fail.
Solution
To resolve this problem, create a remote mailbox in the on-premises environment and then wait for or force directory synchronization to occur. To do this, follow these steps:
Create an on-premises object for the cloud mailbox by using the New-RemoteMailbox cmdlet in the Exchange Management Shell.
Note
This object must have the same name, alias, and user principal name (UPN) as the cloud mailbox. For more information, see New-RemoteMailbox.
Set the ExchangeGuid property on the new on-premises object that you created in step 1 to match the cloud mailbox. To do this, follow these steps:
Connect to Exchange Online by using a remote PowerShell.
For more information, see Connect to Exchange Online PowerShell.
Use the Get-Mailbox cmdlet to retrieve the value of the
ExchangeGuid
property of the cloud mailbox. For example, run the following command:Get-Mailbox <MailboxName>| FL ExchangeGuid
For more information, see Get-Mailbox.
Open the Exchange Management Shell on the on-premises Exchange server.
Use the
Set-RemoteMailbox
cmdlet to set the value of theExchangeGuid
property on the on-premises object to the value that you retrieved in step 2b. For example, run the following command:Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
For more information, see Set-RemoteMailbox.
Wait for directory synchronization to occur. Or, force directory synchronization.
For more information, see Synchronize your directories.
Make sure that the Microsoft 365 user object is displayed as Synced with Active Directory.
More information
Still need help? Go to Microsoft Community.
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