Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
Original KB number: 4024024
Symptoms
When you send email messages to a mailbox in Microsoft Exchange Online, the messages aren't delivered, and you receive the following error message:
Remote Server returned '554 4.3.2 mailbox busy; STOREDRV.Deliver.Exception:StoragePermanentException.MapiExceptionMaxObjsExceeded; Failed to process message due to a permanent exception with message Cannot complete delivery-time processing.
Cause
This problem may occur if the mailbox has reached the limit of items in a folder. In Exchange Online, the limit is one million.
Resolution
To resolve this problem, move emails from the folder that contains one million items to another folder or to an archive.
More information
To find the number of items within each folder in a mailbox, run the following PowerShell command:
Get-MailboxFolderStatistics -Identity <UPN> | FT Name, FolderPath, ItemsInFolder -AutoSize
For more information about the limits, see Exchange Online limits.
Still need help? Go to Microsoft Community.