Note
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Access to this page requires authorization. You can try changing directories.
Symptoms
When you work with contacts, you experience symptoms such as the following:
Calls from Microsoft Graph to run operations on the Contacts folder fail and return a "503" or "504" error message.
Mail clients experience performance issues or stop responding.
Cause
We strongly recommend that you have no more than 10,000 items in your Contacts folder. This is because of the high input and output activity that occurs when you work with contacts. Although the 10,000-item limit is not enforced by Exchange Online, you might experience performance issues if you exceed this number.
Resolution
Use Microsoft Outlook to check the number of items in the Contacts folder in Cached Exchange mode. If the amount exceeds 10,000, delete some contacts to help mitigate performance issues.
To determine the number of items in the Contacts folder, follow these steps:
Open the People pane in Outlook, then right-click Contacts.
Select Properties.
On the General tab, select Show total number of items.
Select the Synchronization tab.
The number of items in the folder is displayed in the Statistics for this folder section.
To delete contacts, use either Outlook or Outlook on the web. If you receive an error message when you try to delete multiple contacts simultaneously, select fewer contacts, and then try again.