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Symptoms
Consider the following scenario:
You migrate an on-premises user mailbox to Microsoft Exchange Online.
After migration, the mailbox user creates a new Microsoft Outlook profile.
In that scenario, folders that were listed as Favorites prior to migration are no longer listed as Favorites in the Outlook client.
Outlook on the web doesn't have this issue.
Cause
Each Favorites folder has a MailboxDN
field value within the PR_WLINK_STORE_ENTRYID
property value that associates the folder with the mailbox. Prior to mailbox migration, the MailboxDN
field value reflects the LegacyExchangeDN
property value of the on-premises mailbox.
When the mailbox is migrated to the cloud, Exchange Online applies a new LegacyExchangeDN
value to the cloud mailbox. However, Exchange Online doesn't update the MailboxDN
field value of each Favorites folder to the new LegacyExchangeDN
value. If the mailbox user continues to use their existing Outlook profile after migration, the Favorites folders appear as usual in the Outlook client. However, if the user creates and uses a new Outlook profile, the mismatch between the MailboxDN
value of each folder and the LegacyExchangeDN
value of the Exchange Online mailbox causes the Favorites folders to not appear in the Outlook client.
Workaround
To work around this issue, mailbox users can use either of the following workarounds.
Workaround 1 (recommended)
Manually re-add folders to Favorites in the Outlook client.
Workaround 2
Use the MFCMAPI tool to manually update the MailboxDN
value of each folder that should appear in the Favorites list.
Important
Although the MFCMAPI editor is supported, you should use caution when you use this tool to change mailboxes. Using the MFCMAPI editor incorrectly can cause permanent damage to a mailbox.
Follow these steps in the user's new profile:
Note the name of a Favorites folder that is visible. If none are visible, add a folder to Favorites to create a visible folder.
Note the names of all Favorites folders that don't appear in the Favorites list.
For the Favorites folder that does appear in the Favorites list:
Copy the hexadecimal value from the Binary section of the editor.
Select Cancel to close the editor, and then close the Properties window for the folder.
For each Favorites folder that doesn't appear in the Favorites list, perform the following steps:
Replace the entire hexadecimal value in the Binary section of the editor with the hexadecimal value that you copied in Step 4.
Select OK to save the value and close the editor, and then close the Properties window for the folder.
Close all MFCMAPI windows to exit the application.
Start Outlook and verify that the Favorites folder collection that you had prior to migration is restored.
Common MFCMAPI procedures
Open the associated contents table in MFCMAPI
If you don't already have MFCMAPI installed, follow these steps:
Determine whether your Outlook installation is a 32-bit or 64-bit version by checking File > Office account > About Outlook.
Download and extract the latest 32-bit or 64-bit MFCMAPI release to match your Outlook installation.
Make sure that Outlook is closed, and then run MFCMapi.exe. If the MFCMAPI startup screen appears, close it.
Select Session > Logon to open the Choose Profile window.
Select the new profile for the user's mailbox, and then select OK.
Double-click the mailbox SMTP address in the Display Name column to open the Root Mailbox window for the mailbox.
In the left pane, select Root Mailbox > Common Views to open the applicable right-pane view.
In the right-pane, double-click PR_FOLDER_ASSOCIATED_CONTENTS to open the Associated contents table.
Open the PR_WLINK_STORE_ENTRYID editor for a folder
In the Associated contents table, locate the name of the folder in the PR_SUBJECT column.
Double-click the folder's name to open its Properties window.
In the Properties window, double-click the PR_WLINK_STORE_ENTRYID entry in the Name column. This will open the Property Editor window for the folder.