Error during mailbox migration from Google Workspace to Microsoft 365
Symptoms
When you do a mailbox migration from Google Workspace to Microsoft 365, the migration fails and returns the following error message:
Error MigrationPermanentException: Special credentials are required in order to access this IMAP account. --> Imap server reported an error during LOGIN with the following alert: 'Application-specific password required:
https://support.google.com/accounts/answer/185833
(Failure).
If you generate a diagnostic report about the migration, you'll see the same error message listed in the report.
Cause
To migrate a mailbox from Google Workspace to Microsoft 365, you must set up 2-step verification and an app password for the mailbox.
If the Google Workspace mailbox isn't assigned an app password, the Microsoft 365 migration service can't access it during the migration. Instead, the service displays an error message.
Resolution
To resolve this issue, set up an app password for the Google Workspace mailbox:
Sign in to the Google Workspace mailbox.
Select the mailbox account (profile), and then select Manage your Google Account.
Select the Security tab.
Under Signing in to Google, select App passwords.
Enter the password to sign in to your Google Workspace account.
In the Select app list, select Other (Custom name).
Enter a name, such as Migration, and then select GENERATE.
Note the generated app password, and then select DONE.
In the CSV file for the migration, add the generated app password in the Password column.
Start the migration wizard in the Exchange admin center.
Locate the failed migration batch, select the affected mailbox, and then select Resume migration.
The migration should finish successfully.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.