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Error during mailbox migration from Google Workspace to Microsoft 365

Symptoms

When you do a mailbox migration from Google Workspace to Microsoft 365, the migration fails and returns the following error message:

Error MigrationPermanentException: Special credentials are required in order to access this IMAP account. --> Imap server reported an error during LOGIN with the following alert: 'Application-specific password required: https://support.google.com/accounts/answer/185833 (Failure).

If you generate a diagnostic report about the migration, you'll see the same error message listed in the report.

Cause

To migrate a mailbox from Google Workspace to Microsoft 365, you must set up 2-step verification and an app password for the mailbox.

If the Google Workspace mailbox isn't assigned an app password, the Microsoft 365 migration service can't access it during the migration. Instead, the service displays an error message.

Resolution

To resolve this issue, set up an app password for the Google Workspace mailbox:

  1. Sign in to the Google Workspace mailbox.

  2. Select the mailbox account (profile), and then select Manage your Google Account.

    Screenshot of the account page with the Manage your Google Account button.

  3. Select the Security tab.

    Screenshot of the Google Account page. The Security menu is selected.

  4. Under Signing in to Google, select App passwords.

    Screenshot of the Signing into Google page. The App passwords option is highlighted.

  5. Enter the password to sign in to your Google Workspace account.

  6. In the Select app list, select Other (Custom name).

    Screenshot of the App passwords page. The Other (custom name) option is highlighted in the Select app list.

  7. Enter a name, such as Migration, and then select GENERATE.

  8. Note the generated app password, and then select DONE.

    Screenshot of the Generated app password page with the password.

  9. In the CSV file for the migration, add the generated app password in the Password column.

    Screenshot of the migration CSV file. The Password column has no app password.

  10. Start the migration wizard in the Exchange admin center.

  11. Locate the failed migration batch, select the affected mailbox, and then select Resume migration.

    Screenshot of the migration batches page. The Resume migration button is highlighted.

The migration should finish successfully.

Screenshot of a successful migration example that shows the status as synced.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.