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Meeting shows an incorrect time zone for an attendee

Symptoms

Both the organizer and attendee of a meeting work in the same time zone. However, the organizer sees the following message when scheduling the meeting in Outlook on the web or the new Microsoft Outlook for Windows:

<Attendee> is in a different time zone. Use the Scheduling Assistant to select times across time zones.

In the Scheduling Assistant, the organizer sees an incorrect time zone for the attendee.

Note

As an admin, you can verify that the mailbox settings for both the organizer and attendee show the same time zone by running the following cmdlet in Exchange Online PowerShell:

Get-MailboxCalendarConfiguration -Identity <user> | FL WorkingHoursTimeZone

Cause

The work hours of the attendee in Outlook on the web and the new Outlook for Windows are based on an incorrect time zone because of corrupted calendar settings.

Resolution

To fix the issue, use the MFCMAPI tool to reset the work hours of the attendee. Follow these steps.

Note

To use the following procedure, you must have full access permissions to the attendee's mailbox or be the attendee. Run the procedure on a Microsoft Windows-based computer that has the Outlook desktop client installed and an Outlook profile for the attendee's mailbox.

  1. Select File > Office account > About Outlook to determine whether the Outlook installation on the attendee's mailbox is the 32-bit or 64-bit version.

  2. Download and extract the latest 32-bit or 64-bit version of MFCMAPI to match the Outlook installation.

    Important

    Although the MFCMAPI editor is supported, be careful when you use it to change mailbox settings. Using the MFCMAPI editor incorrectly can permanently damage a mailbox.

  3. Close Outlook and Outlook on the web, and then run MFCMapi.exe. If the MFCMAPI startup screen appears, close it.

  4. Select Tools > Options to open the Options window.

  5. Select both the following options, and then select OK:

    • Use the MDB_ONLINE flag when calling OpenMsgStore

    • Use the MAPI_NO_CACHE flag when calling OpenEntry

  6. Select Session > Logon to open the Choose Profile window.

  7. Select the Outlook profile for the attendee, and then select OK.

  8. Double-click the attendee's mailbox in the Display Name column to open it.

  9. In the left pane, navigate to Root Container > Top of Information Store > Calendar.

  10. Right-click Calendar, and then select Open associated contents table.

  11. Delete all entries that have IPM.FlexibleWorkingHours in the Message Class column.

  12. Close all MFCMAPI windows to exit the application.

  13. Open Outlook on the web or the new Outlook for Windows, and then set work hours for the attendee.