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Symptoms
When you try to copy, move, or import more than 1,000 items (such as email messages, contacts, and posts) to a public folder in a single Microsoft Outlook session, only about 400 items are processed. In this situation, you receive one of the following error messages:
-
Can't move the items. The item could not be moved. The items may have been already moved or deleted.
-
Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
For example, you try to import a .pst or .csv file that contains more than 1,000 items. However, only about 400 items are imported to a public folder in Outlook.
Cause
Microsoft Exchange Server has a hard limit on the number of items that can be opened by a single mailbox during a single Outlook session. If the number of open items in Outlook exceeds this limit, Outlook takes some time to release the opened items. Therefore, the copy, move, or import operation of those items to a public folder in Online mode doesn't finish, and the following exceptions are raised:
- TooManyObjectsOpenedException
- MapiExceptionSessionLimit
Resolution
To fix this issue, open Outlook in Cached Exchange mode for copy, move, or import operations to public folders that involve more than 1,000 items. Outlook will retrieve the required information from the offline Outlook Data File (.ost) in Cached Exchange mode. Use the following process:
- Download public folders in Cached Exchange Mode.
- Add public folders to Favorites in Outlook.
- Copy, move, or import items to the public folder under Favorites.