Note
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Access to this page requires authorization. You can try changing directories.
Symptoms
In Microsoft Outlook, if a user who has sufficient permissions to a public folder tries to expand the public folder tree, the following error message is displayed:
Unable to expand folder. failed attempt to connect to Microsoft Exchange.
In Outlook on the web, if the user tries to add the public folder to Favorites, the "adding public folder" window does not appear. Additionally, if you look for the GetFolder request by using the F12 diagnostic tools, you can capture the following error message in the response text:
"Mailbox must be accessed as owner. Owner: public folder mailbox guid; Accessing user: User ExchangelegacyDN"
Note
Microsoft does not support third-party solutions that allow access to public folder information through impersonation without a licensed user getting access to the folder through default permissions.
Cause
This issue occurs if the user has explicit permissions, such as Full Access, to the EffectiveDefaultPublicFolderMailbox property.
To verify this condition, run the following cmdlets:
Get-Mailbox <mailbox name of the affected user> | FL *public*
Get-MailboxPermission <EffectiveDefaultPublicFolderMailbox name>
For example:
Resolution
To fix this issue, run the Remove-MailboxPermission cmdlet to remove the explicit permissions to the EffectiveDefaultPublicFolderMailbox property:
Remove-MailboxPermission pfmbx1 -User exo1 -AccessRights FullAccess
Next, run the Get-MailboxPermission cmdlet to verify that those explicit permissions are removed:
Get-MailboxPermission pfmbx1