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"No active public folder mailboxes were found" error and migration batch fails at Complete-MigrationBatch command

Symptoms

You are migrating public folders from Microsoft Exchange Server 2019, 2016, or 2013 on-premises to Exchange Online. The on-premises environment has multiple Active Directory (AD) domains.

When you run the Complete-MigrationBatch command, the migration batch goes into a failed state and generates the following error message:

Screenshot of the Get-MigrationBatch command.

Screenshot of the Complete-MigrationBatch error message.

"No active public folder mailboxes were found. This happens when no public folder mailboxes are provisioned or they are provisioned in 'HoldForMigration' mode."

Cause

This problem occurs because the public folder mailbox and associated user account aren't in the same AD domain. For example, the user account that's associated with the public folder mailbox is in contoso.com, and the mailbox is hosted in Exchange Server in child.contoso.com.

Resolution

To fix this problem, move the AD account that's associated with the public folder mailbox to the same AD domain that hosts Exchange Server. For example, Exchange Server is installed in the root AD domain (contoso.com), and the AD account that's associated with the public folder mailbox is in the child domain (child.contoso.com). In this case, move the AD account that's associated with the public folder mailbox to the root domain (contoso.com), and then run the Complete-MigrationBatch command again. Depending on the version of the operating system, you can either use Active Directory Migration Tool or the Move-ADObject command to move the AD user between domains.

For example, run the following PowerShell command to move the AD user that's associated with PFMBX4 from child.contoso.com to contoso.com:

Move-ADObject -Identity "CN=PFMBX4,CN=Users,DC=Child,DC=contoso,DC=com" -TargetPath "CN=Users,DC=contoso,DC=com" -TargetServer dc1.contoso.com