Senders don't receive Out of Office notifications from a Microsoft 365 user when Forwarding is enabled
Original KB number: 2866165
Symptoms
People who send an email message to a Microsoft 365 user who set up an Out of Office notification don't receive the notification. However, an Out of Office MailTip for the user is displayed in the mail clients of the senders.
Cause
This issue may occur if one of the following conditions is true:
- An external forwarding rule, or an automatic reply notification is set up in the user's mailbox.
- A global Exchange transport rule is created for this mailbox.By design, a mailbox cannot have forwarding rules and an Out of Office notification active at the same time.
Resolution - Step 1: Identify and remove the forwarding rule
To identify and remove a forwarding rule from an Exchange Online mailbox, follow these steps:
Connect to Exchange Online by using Windows Remote PowerShell.
Run the following command:
Get-mailbox -identity <UserID> | FL *forwarding*,*deliver*
If forwarding is enabled on the mailbox, the command output resembles the following example:
ForwardingAddress: ForwardingSmtpAddress: abc@contoso.com DeliverToMailboxAndForward: True
If forwarding is enabled, disable it by running the following command:
Set-Mailbox -Identity <UserID> -DeliverToMailboxAndForward $false -ForwardingSMTPAddress $null
Resolution - Step 2: Identify and remove Exchange transport rules
To identify and remove Exchange transport rules from an Exchange Online mailbox, follow these steps:
Run the following command:
Get-TransportRule | FL Name,Description
If Exchange transport rules are enabled, follow these steps:
- Sign in to the Microsoft 365 portal as an administrator.
- To open the Exchange admin center, select Admin, and then select Exchange.
- In the navigation pane, select mail flow, clear the rules that you want to delete, and then press Delete.
Workaround
To set up email forwarding rules and an Out of Office notification at the same time, you have to set up Inbox rules for the mailbox instead of setting up a transport rule. To do so, follow these steps:
- Sign in to the Microsoft 365 portal as an administrator.
- To open the Exchange admin center, select Admin, and then select Exchange.
- In the upper-right corner, select your name, and then select Open Another user.
- Select Organize Mail, and then select Inbox Rules.
- Select New (
), and then select Create a new rule for arriving messages.
- In the Name box, specify a name for the rule, and then select More options.
- Under When the Message Arrives, select Apply to all messages.
- Under Do the Following, point to Move, copy or delete, and then select Copy the Message to the Folder.
- Select the Select Folder option, and then select Inbox.
- Select Add Conditions.
- Under Forward the Messages to, select User whom you have to forward.
- Select Save.
Note
If you want to forward the message to a user outside your organization, you must add that user as an external contact.
More information
- For more information about mail contacts, see Manage mail contacts.
- For more information about how to use the Out of Office functionality in Exchange Online, see Send automatic replies when you're out of the office.
- For more information about how to create rules to forward mail, see Use rules to automatically forward messages.
- For more information about how to set up automatic replies, see Automatic replies (formerly Out of Office assistant).
Still need help? Go to Microsoft Community.
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