Can't access the mailbox of an unlicensed user in Exchange Online
Original KB number: 3158794
Symptoms
You want to access the mailbox of an unlicensed user in Exchange Online, but you can't locate the mailbox. For example, the mailbox isn't listed in the Exchange admin center or in the output of the following PowerShell cmdlets:
Get-Mailbox -Identity <mailbox ID> -SoftDeletedMailbox
Get-Mailbox -Identity <mailbox ID> -IncludeInactive
Cause
For a regular user mailbox in Exchange Online that doesn't have a hold applied, Exchange Online immediately disconnects (disables) the mailbox if the Exchange Online license for the user is removed or expires. You can't access a disconnected mailbox.
Resolution
To reconnect the mailbox, reassign an Exchange Online license to the user within 30 days from when the license was removed. After 30 days, Exchange Online permanently deletes the mailbox, and the mailbox becomes unrecoverable.
Note
In an Exchange hybrid environment, if a cloud user that's synced from on-premises becomes unsynced, Exchange Online deletes the user. If the deleted user is unlicensed, you must restore the deleted user before you can reassign their Exchange Online license.