Microsoft Online Services Directory Synchronization tool stops syncing objects and triggers a Directory Synchronization error
Problem
You notice that synchronization of objects from your local Active Directory Domain Services to Microsoft cloud services has stopped. (These services may include Microsoft 365, Microsoft Azure, and Microsoft Intune.)
Additionally, Event ID 0, or Event ID 109 is logged in Event Viewer:
Event ID: 0 or Event ID: 109
Source: Directory Synchronization
Description: This version of the Microsoft Online Services Directory Sync tool is no longer supported. Uninstall this version, and then download and install the latest version from your Admin Portal page.
Cause
This issue occurs if you're using a deprecated version of the Microsoft Online Services Directory Synchronization tool. We no longer accept connections to Microsoft Entra ID if you're using a deprecated version of the Microsoft Online Services Directory Synchronization tool.
Solution
Upgrade to Microsoft Entra Connect. This tool must be installed on a 64-bit version of Windows Server. For more information about how to upgrade from DirSync, see Microsoft Entra Connect: Upgrade from DirSync.
More information
For more information about hybrid identity with Microsoft Entra ID, see Prepare for directory synchronization.
For more information about the system and software requirements for Microsoft Entra Connect, see Prerequisites for Microsoft Entra Connect.
For more information about the attributes that are synchronized by Microsoft Entra Connect, see Microsoft Entra Connect Sync: Attributes synchronized to Microsoft Entra ID.
Still need help? Go to Microsoft Community, or Microsoft Entra Forums.