Network issues guide

This guide shows you how to detect network issues or optimization opportunities in the Network panel of Microsoft Edge DevTools.

To learn the basics of the Network tool, see Inspect network activity.

Queued or stalled requests

Symptoms

Six requests are downloading simultaneously. After that, a series of requests are queued or stalled. Once one of the first six requests finishes, one of the requests in the queue starts.

In the Waterfall in the following figure, the first six requests for the edge-iconx1024.msft.png asset start simultaneously. The subsequent requests are stalled until one of the original six finishes.

An example of a queued or stalled series in the Network panel

Causes

Too many requests are being made on a single domain. On HTTP/1.0 or HTTP/1.1 connections, Microsoft Edge allows a maximum of six simultaneous TCP connections per host.

Fixes

  • Implement domain sharding if you must use HTTP/1.0 or HTTP/1.1.

  • Use HTTP/2. Don't use domain sharding with HTTP/2.

  • Remove or defer unnecessary requests so that critical requests download earlier.

Slow Time To First Byte (TTFB)

Symptoms

A request spends a long time waiting to receive the first byte from the server.

In the following figure, the long, green bar in the Waterfall indicates that the request was waiting a long time. This was simulated using a profile to restrict network speed and add a delay.

An example of a request with a slow Time To First Byte

Causes

  • The connection between the client and server is slow.

  • The server is slow to respond. Host the server locally to determine if it is the connection or server that is slow. If you still get a slow Time To First Byte (TTFB) when accessing a local server, then the server is slow.

Fixes

  • If the connection is slow, consider hosting your content on a CDN or changing hosting providers.

  • If the server is slow, consider optimizing database queries, implementing a cache, or modifying your server configuration.

Slow content download

Symptoms

A request takes a long time to download.

In the following figure, the long, blue bar in the Waterfall next to the png means it took a long time to download.

An example of a request that takes a long time to download

Causes

  • The connection between the client and server is slow.

  • A lot of content is being downloaded.

Fixes

  • Consider hosting your content on a CDN or changing hosting providers.

  • Send fewer bytes by optimizing your requests.

Note

Portions of this page are modifications based on work created and shared by Google and used according to terms described in the Creative Commons Attribution 4.0 International License. The original page is found here and is authored by Kayce Basques (Technical Writer, Chrome DevTools & Lighthouse) and Jonathan Garbee (Google Developer Expert for Web Technology).

Creative Commons License This work is licensed under a Creative Commons Attribution 4.0 International License.