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Fix screen sharing video display lag issue in Teams

Symptoms

During a call in Microsoft Teams, when you share a video or other content that requires a higher frame rate for optimal viewing, the display for the other attendees appears to lag and frames are intermittently dropped.

Cause

By default, the frame rate for screen sharing in Teams is set to a low frame rate. This is because commonly shared content, such as an Excel workbook or Word document, is static. The low frame rate makes sure that attendees see the highest possible resolution of the shared content.

However, the default setting can be problematic when a user shares a video. The video may appear to lag because of the low frame rate.

Resolution

In Teams 1.6.00.12455 and later versions, you can use a keyboard shortcut to enable high-motion screen sharing. Follow these steps:

  1. Start sharing your screen in Teams.

  2. Select the Teams app, and then select Ctrl+Alt+Shift+T.

The resolution of the shared content might drop to accommodate the higher frame rate. This depends on several factors, such as device capability and available bandwidth.

Note

The keyboard shortcut will be deprecated soon. There is a new presenter control toolbar that enables a user to optimize for video when screen sharing. For more information, see Share content in Microsoft Teams meetings.

More information

After you run the keyboard shortcut, you won't see any visual indication that high-motion viewing is enabled for you. The keyboard shortcut is a toggle. If you use it two times, the Teams app will return to the default behavior of not forcing high-motion screen sharing.

To check the frame rate for the content that's shared, follow these steps:

  1. In the Teams meeting, select the More menu option.

  2. On the More menu, select Settings, and then select Call health.

  3. To see the frame rate, resolution, and other details about the screen-sharing session, scroll to the Screen Sharing section.