A website doesn't load in the new Teams desktop client
Symptoms
When you select the Website tab in a chat, channel, or meeting in Microsoft Teams, the site doesn't load correctly.
Cause
This issue might occur in either of the following situations:
- The website is prevented from being embedded in other sites.
- Conditional Access policies are enforced in your organization. For more information, see Tabs not working after enabling Conditional Access.
Workaround
To work around the issue, select Open in browser in the following banner to open the site in a new browser tab outside Teams.
Or, if the content can be loaded by a corresponding app, use that app instead. For example, if you want to load a SharePoint page in a channel, use the SharePoint Pages app.