Outlook repeatedly prompts for credentials when using MAPI over HTTP to connect to Exchange
Article
Applies to:
Outlook 2010, Outlook 2016
Original KB number: 4051374
Symptoms
You change the protocol that your Outlook clients use to access Microsoft Exchange Server from RPC over HTTP to MAPI over HTTP. After the change, Outlook 2016 or Outlook 2010 users are repeatedly prompted for credentials to connect to Exchange Server.
Cause
This issue occurs because Outlook 2016 or 2010 keeps trying to use the credentials that were cached for the old RPC over HTTP protocol.
Workaround
To work around this issue, remove the cached credentials from Credential Manager on the users' computers. To do this, follow these steps:
In Control Panel, click User Accounts > Credential Manager > Windows Credentials.
Remove all credentials that start with MicrosoftOffice15_Data:SSPI or MicrosoftOffice16_Data:SSPI.
Restart Outlook.
Enter the user credential in the format of domain/user.
Group policy setting consideration
If you use MAPI over HTTP and the Authentication with Exchange Server Group Policy setting for Outlook, you must update the setting to use the Kerberos/NTLM Password Authentication that MAPI over HTTP uses as the authentication method.
This module examines how clients connect to Microsoft 365. It also provides instruction on how to configure name resolution and Outlook clients, and how to troubleshoot client connectivity.