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Actionable messages render incorrectly

Symptoms

Actionable messages are rendered incorrectly in Microsoft Outlook.

The following screenshot shows an Actionable message that's rendered correctly.

Screenshot of an actionable message that is rendered correctly.

The following screenshot shows the same Actionable message if it's rendered incorrectly.

Screenshot of an actionable message that is rendered incorrectly.

Cause

To render Actionable messages correctly, Outlook uses the following GET request to get the Actions protocol endpoint URL from the Autodiscover V2 service: https://outlook.office365.com/autodiscover/autodiscover.json/v1.0/<user email address>?protocol=actions.

If the request is successful, the Autodiscover V2 service returns HTTP status code 200 and provides the requested URL in the response body. For example, the response body might be { "Protocol": "Actions", "Url": https://outlook.office365.com/actionsb2netcore }.

However, if the Autodiscover V2 service is disabled on the user's computer that has Outlook installed, the GET request fails, and Outlook can't connect to the actions protocol endpoint.

Note

The Autodiscover V2 service is disabled if the DisableAutodiscoverV2Service registry entry exists under the Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover subkey, and the DWORD value of the DisableAutodiscoverV2Service entry is 1.

Resolution

To fix the issue, follow these steps to enable the Autodiscover V2 service on the user's computer that has Outlook installed.

Important

This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For protection, back up the registry before you modify it so that you can restore it if a problem occurs. For more information about how to back up and restore the registry, see How to back up and restore the registry in Windows.

  1. If the user's computer is domain-joined and your organization controls Autodiscover by using Group Policy, make sure that the Disable the Autodiscover V2 service option isn't enabled in the Disable Autodiscover group policy.

  2. Run regedit on the user's computer that has Outlook installed.

  3. Navigate to the Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover registry subkey.

  4. Either set the DWORD value of the DisableAutodiscoverV2Service registry entry to 0 or delete the registry entry.

  5. Delete the following Autodiscover cache files:

    1. %LocalAppData%\Microsoft\Outlook\<any partial file name> - Autodiscover.xml

    2. %LocalAppData%\Microsoft\Outlook\16\<any file name>.xml

    3. %LocalAppData%\Microsoft\Outlook\16\<any file name>.json

  6. Restart Outlook.