Get-AzSentinelEntityQuery
Syntax
List (Default)
Get-AzSentinelEntityQuery
-ResourceGroupName <String>
-WorkspaceName <String>
[-SubscriptionId <String[]>]
[-Kind <String>]
[-DefaultProfile <PSObject>]
[<CommonParameters>]
Get
Get-AzSentinelEntityQuery
-Id <String>
-ResourceGroupName <String>
-WorkspaceName <String>
[-SubscriptionId <String[]>]
[-DefaultProfile <PSObject>]
[<CommonParameters>]
GetViaIdentity
Get-AzSentinelEntityQuery
-InputObject <ISecurityInsightsIdentity>
[-DefaultProfile <PSObject>]
[<CommonParameters>]
Description
Examples
Example 1: List all Entity Queries
Get-AzSentinelEntityQuery -ResourceGroupName "myResourceGroupName" -workspaceName "myWorkspaceName"
DisplayName : Related entities
DataSource : {SecurityAlert}
Name : 98b974fd-cc64-48b8-9bd0-3a209f5b944b
InputEntityType : SecurityAlert
DisplayName : Related alerts
DataSource : {SecurityAlert}
Name : 055a5692-555f-42bd-ac17-923a5a9994ed
InputEntityType : Host
This command lists all Entity Queries under a Microsoft Sentinel workspace.
Example 2: Get an Entity Query
Get-AzSentinelEntityQuery -ResourceGroupName "myResourceGroupName" -workspaceName "myWorkspaceName" -Id "myEntityQueryId"
DisplayName : Related entities
DataSource : {SecurityAlert}
Name : 98b974fd-cc64-48b8-9bd0-3a209f5b944b
InputEntityType : SecurityAlert
QueryTemplate : let GetAlertRelatedEntities = (v_SecurityAlert_SystemAlertId:string){
SecurityAlert
| where SystemAlertId == v_SecurityAlert_SystemAlertId
| project entities = todynamic(Entities)
| mv-expand entities
| project-rename entity=entities};
GetAlertRelatedEntities('<systemAlertId>')
This command gets an Entity Query.
Example 3: Get an Entity Query by object Id
$EntityQueries = Get-AzSentinelEntityQuery -ResourceGroupName "myResourceGroupName" -workspaceName "myWorkspaceName"
$EntityQueries[0] | Get-AzSentinelEntityQuery
DisplayName : Related entities
DataSource : {SecurityAlert}
Name : 98b974fd-cc64-48b8-9bd0-3a209f5b944b
InputEntityType : SecurityAlert
QueryTemplate : let GetAlertRelatedEntities = (v_SecurityAlert_SystemAlertId:string){
SecurityAlert
| where SystemAlertId == v_SecurityAlert_SystemAlertId
| project entities = todynamic(Entities)
| mv-expand entities
| project-rename entity=entities};
GetAlertRelatedEntities('<systemAlertId>')
This command gets a Entity Query by object.
Parameters
-DefaultProfile
The DefaultProfile parameter is not functional.
Use the SubscriptionId parameter when available if executing the cmdlet against a different subscription.
Parameter properties
Type: PSObject
Default value: None
Supports wildcards: False
DontShow: False
Aliases: AzureRMContext, AzureCredential
Parameter sets
(All)
Position: Named
Mandatory: False
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
-Id
entity query ID
Parameter properties
Type: String
Default value: None
Supports wildcards: False
DontShow: False
Aliases: EntityQueryId
Parameter sets
Get
Position: Named
Mandatory: True
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
Identity Parameter
To construct, see NOTES section for INPUTOBJECT properties and create a hash table.
GetViaIdentity
Position: Named
Mandatory: True
Value from pipeline: True
Value from pipeline by property name: False
Value from remaining arguments: False
-Kind
The entity query kind we want to fetch
Parameter properties
Type: String
Default value: None
Supports wildcards: False
DontShow: False
Parameter sets
List
Position: Named
Mandatory: False
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
-ResourceGroupName
The name of the resource group.
The name is case insensitive.
Parameter properties
Type: String
Default value: None
Supports wildcards: False
DontShow: False
Parameter sets
List
Position: Named
Mandatory: True
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
Get
Position: Named
Mandatory: True
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
-SubscriptionId
The ID of the target subscription.
Parameter properties
Type: String [ ]
Default value: (Get-AzContext).Subscription.Id
Supports wildcards: False
DontShow: False
Parameter sets
List
Position: Named
Mandatory: False
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
Get
Position: Named
Mandatory: False
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
-WorkspaceName
The name of the workspace.
Parameter properties
Type: String
Default value: None
Supports wildcards: False
DontShow: False
Parameter sets
List
Position: Named
Mandatory: True
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
Get
Position: Named
Mandatory: True
Value from pipeline: False
Value from pipeline by property name: False
Value from remaining arguments: False
CommonParameters
This cmdlet supports the common parameters: -Debug, -ErrorAction, -ErrorVariable,
-InformationAction, -InformationVariable, -OutBuffer, -OutVariable, -PipelineVariable,
-ProgressAction, -Verbose, -WarningAction, and -WarningVariable. For more information, see
about_CommonParameters .
Outputs