Cannot resolve account to activate SAP workflow - Event 3010 (Duet Enterprise)
Applies to: Duet Enterprise for Microsoft SharePoint and SAP
Alert Name: Cannot resolve account to activate SAP workflow feature
Event ID: 3010
Summary
When an SAP Workflow is configured, a specified user account (service account) is used for all workflow transactions between SharePoint Server 2010 and the SAP environment. The SAP system uses this account to send workflow tasks to the computer running SharePoint Server. This user account will also be added as a member of the SAP Workflow Trusted Users group on the workflow site.
Symptoms
The following symptoms might appear:
Activation of the Duet Enterprise workflow feature failed.
This event appears in the event log:
Event ID: 3010 Description: Cannot add the configured service account user to the group <SAP Workflow Trusted Users>.
Cause
The service account that was specified for the SAP workflow cannot be resolved on the Web application where the SAP workflow is being activated.
Resolution
Specify the service account for workflow
- Follow the instructions in Configure SAP Workflows (https://go.microsoft.com/fwlink/p/?LinkId=205816) to specify the user service account that will be used for all workflow transactions between SharePoint Server and the SAP system.