Performance Counters
Published : September 27, 2005
One method you can use to monitor DPM server performance is the Performance tool in Administrative Tools. You can configure the monitored data to be saved as a log. You can also configure Performance to generate alerts. For information on how to create and configure performance alerts, see Microsoft Knowledge Base article 324752, “How to create and configure performance monitor alerts in Windows Server 2003,” (https://go.microsoft.com/fwlink/?LinkId=47881).
Note
You can use the DPM Management Pack for Microsoft Operations Manager 2005 (MOM) to centrally monitor the state, health, and performance of multiple DPM servers from a MOM Management Server. For information about downloading the DPM Management Pack, see the DPM Management Pack download site (https://go.microsoft.com/fwlink/?linkid=50208).
Table 3.2 lists counters that can be useful for monitoring DPM server performance. For more information on specific performance counters, see Performance Logs and Alerts Help. Click Start, point to Administrative Tools, and then click Performance. On the Action menu, click Help.
Table 3.2 Performance Counters for Monitoring DPM
Performance Object and Counter |
Description |
Value that Might Indicate a Problem |
Possible Causes |
---|---|---|---|
Memory: Avail/MBytes |
Measures the memory that is available to processes running on the specified DPM server. The Avail/MBytes value is the sum of memory assigned to the standby (cached), free, and zero paged lists. |
< 50 megabytes (MB). Indicates low memory on DPM server. |
|
Processor: % Processor Time |
Measures the percentage of time the processor was busy during the sampling interval. |
> 95% for more than 10 minutes. Indicates very high CPU usage on the DPM server. |
|
Physical Disk: Current Disk Queue Length (for all instances) |
Measures the number of disk requests that are currently waiting and the requests currently being serviced |
> 80 requests for more than 6 minutes. Indicates possibly excessive disk queue length. |
|