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This article provides a resolution for the An unknown error occurred while synchronizing data to Outlook error that occurs after the data in the organizer field is removed in the Microsoft Dynamics CRM web client.
Applies to: Microsoft Dynamics CRM 2011
Original KB number: 2700417
Symptoms
By default, appointment records created in the Microsoft Dynamics CRM web client automatically populate the organizer field as the creating user. However, the data in this field can be removed and is not considered required.
In the Microsoft Dynamics CRM 2011 Outlook client, this may produce the following error during synchronization:
An unknown error occurred while synchronizing data to Outlook.
Cause
The organizer field on the synchronized appointment record is blank.
Resolution
Ensure that the organizer field is appropriately populated on the appointment records that are producing this behavior.
In addition, the following actions can be taken to help mitigate this issue for future occurrences:
- Make the organizer field a required field on the appointment form.
- Create a workflow that fires on create and update of an appointment record to check if the organizer field is blank. If the field is blank, add the owner of the record as the appointment organizer.
- Open the appointment in Outlook and populate the organizer field, then synchronize.
- Create a plugin that ensures that the organizer field is populated when an appointment is created or updated.