The Microsoft Dynamics CRM Email Router stops processing outgoing emails when using Office 365 Exchange Online for mass emails
This article provides a solution to an issue where Microsoft Dynamics CRM Email Router stops processing outgoing emails when using Office 365 Exchange Online for mass emails.
Applies to: Microsoft Dynamics CRM 2011
Original KB number: 2712174
Symptoms
The Microsoft Dynamics CRM Email Router stops processing outgoing emails when using Office 365 Exchange Online for mass emails.
The following error may occur in the Event Viewer Application Log when trying to send more than 1500 emails per day per user using the Microsoft Dynamics CRM Email Router with Office 365 Exchange Online:
An error occurred while processing the outgoing e-mail message with subject "Thank You" for ExchangeOnline
http://crm:5555/orgname
for delivery throughhttps://ch1prd0802.outlook.com/ews/exchange.asmx
. Microsoft.Crm.Tools.Email.Providers.EmailException: Error: An internal server error occurred. The operation failed.
at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.LogEwsResponseErrorWarning(String message, ResponseClassType responseClassType)
at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.ProcessMessageInternal(Entity emailMessage)
at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()"
Cause
There's a limitation with Exchange Online in which a limit of 1500 emails can be sent per day per mailbox. It's documented in the Outlook help & learning.
Resolution
To increase this limit, contact Office 365 support by creating a support incident through the Admin Center of the Office 365 portal.